Vault not starting

Justin

Administrator
Staff member
I just tested this and Vault worked - can you try it in a fresh project and if it still doesn't work list the steps to reproduce?
 

Maximuz24

Member
I just tested this and Vault worked - can you try it in a fresh project and if it still doesn't work list the steps to reproduce?
I tried in a fresh project with latest 2.1.7 and latest agility pack just import anew character after that. the issue what i noticed is some lag in jumping animation. it will move toward vault but will wait for few seconds then only it will jump.
Steps I have done
in add manager I add the animation.
added vault in ability which will be below move towards i.e. second from top. rest all i followed the values from nolen character.
1576
1577
1578
 

Justin

Administrator
Staff member
So we are on the same page does it work correctly in the Agility Pack demo scene?
 

DankP3

Active member
Any chance move toward is active and there are no state settings to accelerate controller move and rotate?
 

Justin

Administrator
Staff member
Does the vault object have two Ability Start Location GameObjects underneath it? In the demo scene there is the front and back start locations.
 

Maximuz24

Member
Does the vault object have two Ability Start Location GameObjects underneath it? In the demo scene there is the front and back start locations.
Hi Can you please try in any other character as its still not working. If Possible please provide video tutorial.
 

Justin

Administrator
Staff member
Hi Can you please try in any other character as its still not working. If Possible please provide video tutorial.
I just tried with Ethan and was able to get it to work. Does your vault object have two Ability Start Location GameObjects underneath it?
 

Maximuz24

Member
I just tried with Ethan and was able to get it to work. Does your vault object have two Ability Start Location GameObjects underneath it?
I check with demo prefab model still one side it works fine another side it still walking.it will work sometimes I think it depends upon camera angle. I change the motor rotation to 100. but why it happens like that.

1568738760940.png
1568739172301.png

1568739387411.png
 
Last edited:

Justin

Administrator
Staff member
On the vault ability (your second screenshot) you can specify how it detects the vault objects. It sounds like you want to increase the Angle Threshold for determining if an object is detected.
 

Maximuz24

Member
On the vault ability (your second screenshot) you can specify how it detects the vault objects. It sounds like you want to increase the Angle Threshold for determining if an object is detected.
When trying in demo scene my character working fine but when i make a new scene its not working front side working fine but back side not working (2nd screen shot.)please help.
1568830325322.png
1568830440788.png
 

Justin

Administrator
Staff member
Did you adjust the angle threshold? Also, have you tried bringing Nolan into your scene to see if that works? If that works then it is a problem with your character so you can go through and ensure the vault values are the same.
 

Maximuz24

Member
Did you adjust the angle threshold? Also, have you tried bringing Nolan into your scene to see if that works? If that works then it is a problem with your character so you can go through and ensure the vault values are the same.
thanks. Vault values are same problem happens was the collider size now its working fine.Thanks
 

Maximuz24

Member
@mncgdev . Add state movetowards in UCC character script and change motor roation speed to 100. also if this didnt solve change collider size of the character.
1587745505026.png

1587745543964.png
1587745587694.png
 

mncgdev

New member
i try to add MoveTowardsUltimateCharacterLocomotionPreset in Unlimate Character Locomotion, but it's say error

Error: Unable to add preset. MoveTowardsUltimateCharacterLocomotionPreset.asset isn't located within the same project directory.
UnityEngine.Debug:LogError(Object)
Opsive.UltimateCharacterController.Editor.Inspectors.StateSystem.StateInspector:AddExistingPreset(Type, State[], ReorderableList, String) (at Assets/Opsive/UltimateCharacterController/Editor/Inspectors/StateSystem/StateInspector.cs:376)
Opsive.UltimateCharacterController.Editor.Inspectors.StateSystem.StateBehaviorInspector:AddExistingPreset() (at Assets/Opsive/UltimateCharacterController/Editor/Inspectors/StateSystem/StateBehaviorInspector.cs:170)
UnityEditor.GenericMenu:CatchMenu(Object, String[], Int32)

and motor rotation speed in MoveTowardsUltimateCharacterLocomotionPreset already 300
 

Attachments

  • errorAddMoveTowardPreset.PNG
    errorAddMoveTowardPreset.PNG
    38.7 KB · Views: 3
  • movetowardRotationSpeed.PNG
    movetowardRotationSpeed.PNG
    27.3 KB · Views: 4
  • movetowards.PNG
    movetowards.PNG
    41.6 KB · Views: 3

Maximuz24

Member
where did you add this preset? i cant see vault ability in the ability list. add move towards in the state of move towards category 3rd image of yours.U need to add preset at the bottom preset of the UltimateCharacterLocomotion .
 
Top