Top Dismount Offset issue? - Free Climb



I can't get the Top Dismount to work when using free climb. If I have it to high, the animation plays to early (as it should). If I lower the value, the animations doesn't play and the character just falls down. I believe the ability index is set to 0 and that's whats causing the fall. When checking the animator monitor it just says that ability index was changed to 0 (see attached image) and after that, that the ability int data is set to 0. If I hadn't disabled fall ability it would show instead.

I have tried changing all of the climb setting but nothing works. I have disabled all other abilities, except move torwards.

If I use the demo character it works. I don't know why it's not working on my character as I have copied all settings and compared the two and can't find what's causing the issue.

Maybe this video help:


  • Free Climb Issue.jpg
    Free Climb Issue.jpg
    270.3 KB · Views: 0
Have you tried enabling Draw Debug Lines to visualize what is happening? You should also compare your ability order to the demo scene ability order.