Issue with first person items/arms not being visible

CraigHubbard

New member
Summary:
I couldn't get the player arms to show up with a new item collection. Switching to a duplicate of the demo item collection resolved the issue.

Steps:
Create a new item collection from scratch in the Item Type Manager.
Create a new character using the Nolan model and first person arms. I unpacked both prefabs and renamed them, but otherwise used the process outlined in the tutorial.
Add item categories named Weapon and Thrown.
Add a new weapon item type set to Weapon category and a corresponding ammo item set to Nothing.
Create the corresponding weapon with the Item Manager.
Run the game.
No weapon or arms are visible.
With the game still running, expand the camera in scene view. Everything below the pivot is grayed out.
Check the console, but no related errors are reported.
Exit play mode and delete both the weapon item and the attached weapon from the Hierarchy.
Select the player and remove the inventory and item set entries for the weapon and ammo.
Change the item collection to a duplicate I created of DemoItemCollection called BaseItemCollection, leaving all demo items as is.
Re-add the weapon using the exact same steps.
Result: the weapon and arms are visible.

Note that I tried duplicating the DemoItemCollection again and adding the weapon to the new copy with no success, so it may be purely coincidental that it worked.

I also tried repeating the steps with a new character and new item collection and got the same result. And I fixed it by the same exact method.

Unity version: 2019.3.11f
Most recent version of First Person Controller.
 

helio

New member
Me and you and many others are having the same problem.
the weapon is invisible.
if you try to shape the character in your project.
the arms are all around and sometimes in places away.
you have to look for arms .hahahahaha ...
I bought this soft, to be faster.
in the end I wasted time.
there is only one solution
fix in scripts.
 

Justin

Administrator
Staff member
As a start have you gone through the video tutorials? Do those work for you?
 

andrew_ES

New member
I am having this same issue.
Unity 2018.4.14f1
UFPS: 2.2.4

I also made duplicates of the models, animators and created my own item collection. If I used my duplicated models and animators with the original demo item collection, the weapon I give (I choose the Pistol) is visible, but if I use my item collection that only contains a pistol and pistol bullet, then they are not visible. I also receive no errors. I tried other permutations of original and duplicates and whenever I used my item collection, the weapon doesn't appear.

I followed the instructions in the documentation pdf and have followed the videos on how to create a new character.

EDIT: I found a partial solution to the issue. In the item collection I was using, I had created two categories called "Items" and "Weapons" and had set the pistol category to Weapons. It must not have been able to recognize it. I tried switching the Pistol to be in the Items category, but it didn't seem to effect anything. I made a new Item collection with only the default "Items" category and created the Pistol entries. When I created a new character with the pistol using this new item collection, it worked. I haven't done too much reading up on Item Type Categories, but does this sound like the desired outcome when changing categories?
 
Last edited:

Justin

Administrator
Staff member
When you switch the category you'll also need to make sure you have an EquipUnequip ability that matches that category. This page lists the troubleshooting steps:


When you're first getting started I recommend following the video tutorials exactly as they are so you get the same results. This will allow you to see the workflow and then you can make modifications.
 
Top