Unable to find the itemSet error message

siendel

New member
As far as I can tell, I have everything set up correctly and even looked through a similar issue someone else had. Except I can't seem to equip weapons from pickups or if I put the items directly into Main or Equippable. So far, I've only tried adding swords, but I get this error when trying to equip "Unable to find the ItemSet for item 1 Sword [id#] ItemCollection Equippable (Secondary) ItemStack [...] in category index 0. Only 'Equippable' has ExposedItemSet set to true.

However, if I put the item in the Loadout collection, then when I start I can equip/unequip fine. Though in this case, for some reason, two copies of the sword get created. One that uses the LocalSpawn rotation/position and the other doesn't (they are flipped 180 degrees from each other) - the second copy seems to get deleted when I unequip and the other gets disabled so maybe it's just that one copy is being rendered when it shouldn't be. Anyways, I was hoping to test this with pickups to see if it was just an issue with the Loadout not working right, but they don't seem to work. I created the pickup prefab by following the integration video, except using a sword instead of an assault rifle. I also duplicated a working UIS pickup except changed the item in it to my item prefab. This has the exact same issue except I also impart physics onto the prefab when I run into it instead of it disappearing (the item still goes into my inventory though). I'm only setting up the items for third person perspective.

Here's how things look set up:
error2.png

error4.pngerror5png.png
 

Sangemdoko

Moderator
Staff member
One of the issues I see is that you are using the Character Equipper which is a UIS demo script. I will be renaming that class because you are the third person that thought it was the right thing to use.

Remove that and hopefully it should work.

If you want to equip clothes create a new Item collection specific to clothes. You'll want to make sure that your clothe items do NOT inherit the Equippable category (maybe rename it WeaponEquippable?) This way they won't be equipped through the UCC system.

Instead you'll use the Equipper (not Character Equipper) class to equip clothes. You'll do so by adding item to that new item collection which you will specify in the Equipper inspector.

In the future I'll show how to do this in the demo scene since it has been requested a few times this week
 

siendel

New member
Thanks! That was the issue with the Loadout not working. My 'Equippable' pickups are still not working though - I get the same message. My clothing pickups (which use a 'wearable' category and my own equipper routine to put clothes on my UMA work fine still). I'll work on this later today and will edit this post if I find a solution.

Update: So it turns out if I started with a weapon, everything worked fine. It was only if I didn't start with a weapon in my loadout that my pickups didn't work. Turns out there was an error I wasn't paying attention to when I tried and pick up the pickups (an error in the camera objectfader script trying to access a null m_CharacterFadeMaterials). I modified line 608 to check for the null condition first: "if (m_CharacterFadeMaterials == null || totalCount >= m_CharacterFadeMaterials.Length) {". This seems to have solved the issue :)
 
Last edited:
Top