Puppet Master causes jittering

Cheo

Member
Hello, I'm reposting something I wrote on the discord server :
Good day everyone, I'm having an issue with the Puppet Master integration : after following each step on the online guide, my ucc character jitters when moving as you can see in this video :
The character is able to get up after getting knocked down as expected though, so that's a good thing !
Has anyone else had this jittering issue with UCC and Puppet Master ?
 

Andrew

Well-known member
Not sure about Puppet Master specifically, but it looks like an update location issue - what update location is your character using? (In UltimateCharacterLocomotion -> Motor)
 

Cheo

Member
Hello, the update location is set to Fixed Update as recommend - I just tested with Update and it made the jittering even worse !
Pretty sure I followed the set up guide correctly, do you have any other idea ?
 

Justin

Administrator
Staff member
I just checked my PuppetMaster integration and the character is using FixedUpdate. It looks like there is a jitter even before going into puppet mode which is strange because at that point PuppetMaster doesn't do anything. Can you create a new character in a new scene and first make sure you aren't getting any jitter. Then take it one step at a time and let us know after what step the jitter is caused. This will help us narrow down the issue.
 

Cheo

Member
I confirm that there is no jittering issue when playing a simple UCC character. Following this guide I would say the jittering occurs at step 17 - but the character is unplayable before that, so it doesn't help us much... I have a question about the puppet master ability though : the guide simply tells to add it and to fill two fields, but are we supposed to leave it at the bottom of the list without changing anything else ? And just to be clear, you have the same jittering issue, it's not just on my end ?
 

Justin

Administrator
Staff member
There is no jitter when I perform those steps. Here's what my Puppet ability looks like:

1611141526165.png

Partel originally created the integration so it may be worth asking him what could cause the jitter when the puppet isn't enabled.
 

byrdmic

New member
I'm also getting the jitter in the PuppetMaster integration scene. Could it have something to do with the Kinematic Object Manager? From looking at the code, it looks like the position is set in Fixed Update and then lerped between the positions in normal Update. If I set Puppet Master's mapping weight to 0 the jitter disappears. Could this be the discrepancy? Something like the lerping between positions causing Puppet Master's mapping to get out of sync or not know exactly where it should be?
 

Justin

Administrator
Staff member
Partel recently created a video showing how to get the integration working:

 
I'm getting the same issue, when I put the mapping weight to 0 the jitter does disappear but the animations aren't accurate
 

raskalgames

New member
Hi! I am having the same issue (also in the example scene, my character jitters). Did anyone find the cause?

Edit: the character jitter only seems to be in the Game view, not in the scene view.
Edit 2: the jitter goes away when the camera controller component (on the camera) is turned off. So it seems to have to do something with the camera controller script.
Edit 3: this seems to be related?
 
Last edited:

JAKAMY

New member
I confirm the same. I use latest UCC with puppetmaster and FinalIk and Grounder full body:
I get camera Jitter with animator to animatephysics and motor to update or fixed updates
I get no camera jitter if animator to update and motor to update.
I get camera jitter if animator to update and motor to update and use the finalik bridge
Another thing is that by using the bridge, Grounder full body biped doesn't work (it stays enabled and I guess it finds Full Body FinalIK disabled.
 

raskalgames

New member
I get no camera jitter if animator to update and motor to update.
Interesting, because I still get the animation jitter when the animator is set to "normal" and motor to update.

I noticed that sliding "previous acceleration influence" to 0, the animation looks more fluid (but still jitters a but and the character moves slower). When I compensate the "slowness" by increasing the acceleration on the z-axis, the character starts jittering again...
 

JAKAMY

New member
Interesting, because I still get the animation jitter when the animator is set to "normal" and motor to update.

I noticed that sliding "previous acceleration influence" to 0, the animation looks more fluid (but still jitters a but and the character moves slower). When I compensate the "slowness" by increasing the acceleration on the z-axis, the character starts jittering again...
Hmm I moved on from this issue while I prototype other things. But I found this, it might be related https://www.opsive.com/forum/index.php?threads/final-ik.298/post-4792
 

Justin

Administrator
Staff member
I do not think that post is related as the jitter has been fixed for a few major releases and haven't gotten any recent vanilla reports. Have you followed Partels guide? I just tried the demo scene and didn't get any jitter.

Combining FinalIK and PuppetMaster is a problem because they both require different update rates. I have not had a chance to look into this yet.
 

raskalgames

New member
I do not think that post is related as the jitter has been fixed for a few major releases and haven't gotten any recent vanilla reports. Have you followed Partels guide? I just tried the demo scene and didn't get any jitter.

Combining FinalIK and PuppetMaster is a problem because they both require different update rates. I have not had a chance to look into this yet.
Hi Justin,

I am following the guide from within Unity (the same that is on the opsive website). Is there another guide, I am not aware off? I can send you my project so you can have a look at what I did wrong.

Edit: I am running Unity 2020.1.9f1 with Puppet Master 1.1.0 and UCC 2.4.4


Edit2: when I do a fresh install of the currently recommended version of Unity 2020.3.25f1, PM and UCC I get the jittery character in the example scene of the integration package that I downloaded from here.
 
Last edited:

Justin

Administrator
Staff member
The guide should be the same but have you tried following the video? This will better show visually how to set it up. Also, are you using FinalIK?
 

raskalgames

New member
The guide should be the same but have you tried following the video? This will better show visually how to set it up. Also, are you using FinalIK?
I won't have time today to try but I will follow the video and record myself and post it here.
I am not using FinalIK yet, but I bought it too with the promise that all 3 assets would work together. I want to make something with all 3 assets working in unison (UCC, PM and FIK).
 

Justin

Administrator
Staff member
I didn't create the PuppetMaster integration so am not familiar with the implementation but will try to look into this. I would also like to be able to support both PuppetMaster and FinalIK at the same time but it'll likely take some work with Partel.
 

raskalgames

New member
I didn't create the PuppetMaster integration so am not familiar with the implementation but will try to look into this. I would also like to be able to support both PuppetMaster and FinalIK at the same time but it'll likely take some work with Partel.
Yeah as these packages are often bought together (and are advertised to work together), I think it'd be great if you guys could figure out why they are no longer compatible.

I followed Partel's guide step by step and I still get the jitter. I am confident it has something to do with the camera implementation but I have no clue what is causing it and how to fix it.
 

JAKAMY

New member
Yeah as these packages are often bought together (and are advertised to work together), I think it'd be great if you guys could figure out why they are no longer compatible.

I followed Partel's guide step by step and I still get the jitter. I am confident it has something to do with the camera implementation but I have no clue what is causing it and how to fix it.
There is a temporary camera fix by FinalIK/Puppetmaster creator. But it doesn't resolve all: https://rootmotion.freshdesk.com/support/discussions/topics/77000263682
 
Top