Errors on Namespaces after importing 2.1.1

I have just updated to 2.1.1 (First deleted the UltimateCharacterController folder as mentioned on the instructions. First imported First Person Controller and after that Third Person Controller) and I have 12 errors related to CINEMACHINE namespaces....

PS: I installed directly 2.1.1 and I deleted the UltimateCharacterController folder (I didn't install first 2.1 and afterwards 2.1.1)

Example:
Assets\Opsive\UltimateCharacterController\Scripts\ThirdPersonController\Camera\ViewTypes\Cinemachine.cs(13,7): error CS0246: The type or namespace name 'Cinemachine' could not be found (are you missing a using directive or an assembly reference?)

EDIT: I had to delete cinemachine.cs in scripts/viewtypes to delete the errors. I even uninstall the cinemachine package, and installed again and didn't work..... I'm not using the old cinemachine asset but the new cinemachine package.
 
Last edited:

Justin

Administrator
Staff member
So you are no longer getting any errors? For cinemachine you'll need to make sure you are using a version greater than 2.1. You could also try importing into a fresh project just as a sanity test.
 
I have the same problem. I also upgraded directly to 2.1.1 without downloading 2.1.

1551519321665.png

What is weird is that the Cinemachine namespace does exist, since I am using it in my own scripts without any issues. I am using the package manager Cinemachine version 2.2.8 btw.

I am guessing the problem has to do with assembly definitions. My scripts are under "Assembly-CSharp" while the Cinemachine.cs and CinemachineSpringExtension.cs scripts are under "Opsive.UltimateCharacterController". Any ideas how to fix it? Since I am using cinemachine I need these scripts. For now, I will copy paste the content of the scripts inside my own script and comment out the contents of your scripts completely, so that I can debug the rest of the errors.
 
Top