Errors After Importing DeathMatchAi and Behavioral Trees Pt 2

drerlee

Member
This is the second time in the past couple of months, Ive tried integrating Deathmatch with Behaviour Trees and the Third Person controller using the latest update for all addons. After failing a few months ago, I gave up and reverted to the older version of all of the opsive addons before your latest updates. FYI, here it is again today I tried integrating your packages using the latest updates from the asset store. Only having to again revert back to the previous working version.
 

Justin

Administrator
Staff member
Make sure you are starting with a fresh project and then import these four packages:


You should also check the version numbers within the asset to ensure you are getting the latest. Depending on the version of Unity that you are using you may be getting an old version of the package with the Package Manager:

Note: The Unity Package Manager doesn’t always import the most recent update after you download the asset. Ensure you are getting the latest by removing the package cache from the Asset Store download folder.
 

drerlee

Member
That is exactly what i did, was start with those four, and i get the same results. The only way I can get it working is by going to my hard drive and retrieving the files for the version before I installed the latest version 2.3.2 of every piece of software you have. I have a plethora of addons i use besides yours, and to have to reinstall all of those before i can verify if your addons work would be ridiculous considering the fact your addons or Deathmatch by Ai are the only things breaking my projects and causing me to have to start over.
 

Justin

Administrator
Staff member
What error are you getting? This will allow me to track down what asset is out of date.
 

drerlee

Member
I keep getting instance name errors, the moment i install the latest deathmatch ai. Ive already killed the project and started a new one with the old version of obsive third person controller version 2.2, behavior designer version 1.6.7, and deathmatch ai kit the version before you updated it in february to version 2.0.1. The link on the unity asset store you have for deathmatch ai kit for the release notes says "Nothing Found" when i go to the page, so i cannot determine what version of deathmatch ai kit im using as you do not list the previous version info in the documentation pdf, nor on the asset store, nor from the link to the release notes. I just know im using the version I believe that is the original from january 21.
 

Justin

Administrator
Staff member
obsive third person controller version 2.2,
That is the problem - you need to update to version 2.3. This also is likely the cause of the PUN add-on errors that you are getting. After you import the character controller from the Asset Store you should run the installer from the Tools -> Opsive -> Ultimate Character Controller menu. Once you do this the Welcome Manager should say 2.3.2. I would first try this in a fresh project.
 

drerlee

Member
You are not reading my posts. I have tried explaining this to you several times. IVE ALREADY TRIED 2.3.2 SEVERAL TIMES IT DOESNT WORK.
 

drerlee

Member
You need to get a dedicated page with instructions and links to all of the appropriate software. For a paid product that requires you to buy all of these other addons from your team, i think thats the least that can be done. These failures come from your default install instructions which should not be happening.
 

Justin

Administrator
Staff member
Version 2.3.2 definitely works with the latest version of deathmatch and pun. There would be a lot more threads if it didn't :) It sounds like the package manager is still downloading the old version of the character controller which is independent of our assets.

Have you confirmed that you are running version 2.3.2 in the welcome manager?
 
Top