Third Person Camera jitter

Shadowing

Member
So one of the large reasons I switched to version 2 of the character controller was this weird Jitter when rotating the character in 3rd person.
I think I showed you this a long time ago before I made the switch @Justin
I'm pretty sure it didn't do this back in 2019 when I first started using version 2.

Video below. As the character rotate he jiggers does it in your demo too.

 

Justin

Administrator
Staff member
If you set the Third Person Combat's Position Smoothing value to 0 then it'll fix it. I'll make this same change in the next update.
 

Shadowing

Member
Thanks Justin
Ya that fixed your demo guy. I can still see him jittering a little though very slightly. Could just be the rotate animation of the legs idk lol.

Unfortuanlly it didn't fix my character in my scene for some reason.


 

Shadowing

Member
Ahh I just noticed if I enable root rotation the character stops rotating of course. But the camera rotates and I can see the jitter. So now I know its a camera at least now. Thought for a while could be character rotating lol. Also does that sound like it rules out the camera keeping up with the character on rotation?
Which is why the settings you told me to change isnt working.

Could this be some sort of mouse input issue?
 

Justin

Administrator
Staff member
For combat you should not enable root motion rotation as unless for very specific scenarios. This will prevent the character from rotating with the character.
 

Shadowing

Member
Alright while I'm trying to figure out this issue. I started a new project.
I noticed a little bug in Ultimate controller.
When you use the manager to setup a Third person camera.
It sets up adventure to act like combat and combat to act like adventure.

so otherwise it opposite of what your demo is set too.


When I have it set to combat by using the camera setting son the demo
I notice my character does this when rotating. Shouldn't the character always be facing forward in combat mode no matter how fast you rotate?
It was hard to tell if your character does this in your demo. This only happens when the player isn't holding a weapon too I believe.

 

Justin

Administrator
Staff member
The character rotation speed is dependent on the motor rotation speed. Adventure mode will behave similar to combat when you are aiming.
 

Shadowing

Member
I"m getting hit with this error when adding all the weapons from the demo when using the existing character tab on the manager


Error: Unable to find the movement type with name Opsive.UltimateCharacterController.FirstPersonController.Character.MovementTypes.Combat.
UnityEngine.Debug:LogError (object,UnityEngine.Object)
Opsive.UltimateCharacterController.Character.UltimateCharacterLocomotion:SetMovementType (System.Type) (at Assets/Opsive/UltimateCharacterController/Scripts/Character/UltimateCharacterLocomotion.cs:566)
 

Shadowing

Member
You can see the jitter issue doesn't happen in that video I posted earlier today too.
So im on a mission now trying to figure out why it happens in my project and not on a fresh project.

I disabled everything in my scene and it still does it.
Thought about starting from scratch since I updated from a version of ultimate controller 2 years ago.
Maybe some layer change or something like that is causing this.

Or maybe its how I have the character anchored. I'll look into that.
 

Shadowing

Member
Ahh @Justin!!! I figured it out. Took like 12 hours lol.

It happens when I don't use the option to Init the character on Awake.
So I assign the Character and Anchor by script on the Camera Controller
Enabled the Camera Controller it after assigning those two references.

So probably some settings to the controller isn't going into effect. Probably Position smoothing.

This thing was driving me crazy for hours so glad I finally figured it out.
Let me know if you can reproduce that.
I didn't try to reproduce it on your demo though. But it defiantly removed the issue on my character and it makes sense since the demo uses the Awake option.
 

Justin

Administrator
Staff member
The jitter happened because of the position smoothing. This is because there is a double smoothing going on between the camera controller and kinematic object manager. The correct fix for this case is to set the smoothing value to 0. You will get the movement type error if you do not have that movement type added to the Movement Type list.
 

Shadowing

Member
Ya I was able to duplicate what you are saying but there is another problem.
If you init the character by script instead of just having the character sitting in the scene on awake. "Like how your demo is" All those smooth settings or something becomes broken.

I have covid righ now. I've been fighting for my life for the last week. I can make a test project and duplicate this in the demo when my strength gets up.
 
Top