Version 2.3.4 and Add-On Updates


Staff member
This page has information on the latest version of the character controller:

Due to a file change the Assets/Opsive/UltimateCharacterController folder should be removed before importing. Make sure to create a backup before removing the folder and ensure you do not have any unique assets stored in the UltimateCharacterController folder.

The following add-ons were also updated:

Agility Pack:
Swimming Pack:
Last edited:


New member
I'm using UCC 2.3.1 + UIS 1.1.5, and I'm going to update both to the newest versions.
I deleted the Assets/Opsive/UltimateCharacterController folder and import UCC from Package Manager, the installer window doesn't show up, I also tried delete the Assets/Opsive/Installer folder and reimport UCC, still no installer window. Is there other way I can install the new version?

I see this thread
So if there are compiler errors then the installer window won't show up, how can I avoid these errors while there are assets referring UCC scripts and I have to delete all of these UCC files?

I successful installed UCC by clicking the package under Assets/Opsive/Installer/UltimageCharacterController, then I had the same problem like this thread: . and solved it by cleaning the cache then download the package and import again.
Last edited: