The rocket launcher can only fire one rocket

cangcloud

Member
I created some weapons, but the rocket launcher can only launch one rocket. After the rocket is launched, it cannot be launched again, nor can it be reloaded, nor can I switch other weapons. I don't know how to solve this problem. It is already the second rocket launcher I created, but all have the same problem. I recorded a video and I need help.
 

DavidC

Active member
I created some weapons, but the rocket launcher can only launch one rocket. After the rocket is launched, it cannot be launched again, nor can it be reloaded, nor can I switch other weapons. I don't know how to solve this problem. It is already the second rocket launcher I created, but all have the same problem. I recorded a video and I need help.
Does your character have the "reload" ability?

1628091838678.png

In the "Game" object, is Rocket in the pool?

Those errors tell you what script (component) is missing what variable.

IE "ThirdPersonShootableWeaponProperties" is a component on the weapon, and m_Reloadable Clip is a field that is currently set to "none." You need to drag in the correct objects for these missing fields to remove the errors. Make sure to open console, fire weapons until the FIRST error you see, then immediately go fix that error on that gun. I say that, because some of your errors are appearing on the guns BEFORE the rocket launcher.
 

cangcloud

Member
Does your character have the "reload" ability?

View attachment 6719

In the "Game" object, is Rocket in the pool?

Those errors tell you what script (component) is missing what variable.

IE "ThirdPersonShootableWeaponProperties" is a component on the weapon, and m_Reloadable Clip is a field that is currently set to "none." You need to drag in the correct objects for these missing fields to remove the errors. Make sure to open console, fire weapons until the FIRST error you see, then immediately go fix that error on that gun. I say that, because some of your errors are appearing on the guns BEFORE the rocket launcher.
I just created a rocket launcher and found this problem. I didn't remove or delete any components. I don't know how this problem occurred. The rocket launcher is not in the pool.
 

Attachments

  • 1.JPG
    1.JPG
    676.5 KB · Views: 3

DavidC

Active member
I just created a rocket launcher and found this problem. I didn't remove or delete any components. I don't know how this problem occurred. The rocket launcher is not in the pool.
1. Did you look for reload like I asked?

2. not "Rocket Launcher." Rocket (see picture) This is the projectile. The thing that is shot or fired.
 

Attachments

  • 1628105154529.png
    1628105154529.png
    66.8 KB · Views: 1

Justin

Administrator
Staff member
I would try comparing your ShootableWeapon settings to the demo scene. Also make sure you have enough ammo. If you have replaced the animations then you will also need to add in any new animation events:

 

cangcloud

Member
I would try comparing your ShootableWeapon settings to the demo scene. Also make sure you have enough ammo. If you have replaced the animations then you will also need to add in any new animation events:

I'm also surprised that the rocket launcher can only launch one rocket with 9 rounds of ammunition. I hope you can find out the reason.
 

Andrew

Moderator
Staff member
Have you compared your ShootableWeapon properties to the demo's rocket launcher as Justin suggested? Also I saw in your video that an error came up about the Smoke Location not being assigned - have you assigned a transform to the "Smoke Location" property in the ThirdPersonShootableWeaponProperties component? And are you getting any other errors?
 

cangcloud

Member
Have you compared your ShootableWeapon properties to the demo's rocket launcher as Justin suggested? Also I saw in your video that an error came up about the Smoke Location not being assigned - have you assigned a transform to the "Smoke Location" property in the ThirdPersonShootableWeaponProperties component? And are you getting any other errors?
Let me check it carefully again. I hope this problem can be solved this time.
 

cangcloud

Member
I would try comparing your ShootableWeapon settings to the demo scene. Also make sure you have enough ammo. If you have replaced the animations then you will also need to add in any new animation events:

I have found the problem. This problem has been solved. Smoke was not created when the rocket launcher was created. After I added it manually, the problem has been solved. You can see my screenshot. I hope these do not need to be added manually in the next version.
 

Attachments

  • M%}R7I(T)~V0`J%4UQ(1Q9W.png
    M%}R7I(T)~V0`J%4UQ(1Q9W.png
    819.9 KB · Views: 1

cangcloud

Member
Have you compared your ShootableWeapon properties to the demo's rocket launcher as Justin suggested? Also I saw in your video that an error came up about the Smoke Location not being assigned - have you assigned a transform to the "Smoke Location" property in the ThirdPersonShootableWeaponProperties component? And are you getting any other errors?
I have found the problem. This problem has been solved. Smoke was not created when the rocket launcher was created. After I added it manually, the problem has been solved. You can see my screenshot. I hope these do not need to be added manually in the next version.
 

Attachments

  • M%}R7I(T)~V0`J%4UQ(1Q9W.png
    M%}R7I(T)~V0`J%4UQ(1Q9W.png
    819.9 KB · Views: 1

DavidC

Active member
I have found the problem. This problem has been solved. Smoke was not created when the rocket launcher was created. After I added it manually, the problem has been solved. You can see my screenshot. I hope these do not need to be added manually in the next version.
I recommend, in the future, try and resolve every red error, even if it seems unrelated. Red errors have a way of breaking many things.
 
Top