New project UCC 2.3.4 numerous compiler errors on import of Deathmatch AI

Chuck Terzian

New member
Hey Devs,

So I've successfully imported the Deathmatch AI kit in a different project but I thin kit was the previous version of UCC that was installed there. But now in a new project with UCC 2.3.4, Behavior Designer, and the Formations, Movement, Tactical packs installed... I am getting about 24 compiler errors when after install of the Deathmatch AI kit. I've already spent about an hour doing different order of operations for installing but no matter what, when I install the Deathmatch AI kit it throw those 24 compiler errors. Attached is a screen shot of the errors.

Any help you can provide is much appreciated.

Screenshot 2021-07-15 072957.png
 

Chuck Terzian

New member
I got it working without errors now. There's a Behavior Designer integration Unity Package that I didn't install. Instructions are here for others who may be starting a new project fresh and not remember to install it.

 
Top