Master client lag

nathanj

Member
Hi Justin

There is something really weird about the master client when the character controller is set to Third Person Combat . The camera lags when you spin quickly and the jumping doesn't work - it kind of does but it's not a complete jump.

It's only the master client, but always happens.

Any idea what could cause this?
 

nathanj

Member
Hi Justin,

I can't see any bottle neck. My framerate is currently 140fps. Must be a setting in my project because i did try the demo and it appears to act normal. I'll post back if i figure out what this is.

However, one thing I did notice, in both the deme and my scene is that I can not add items to theRuntime Pickups component. In the demo scene there are two items already added to the component but you can not add any more to it. None of the other items can be added.

Thanks again,
Nathan
 

Justin

Administrator
Staff member
Are you referring to the PunItemPickup component? I was able to add another PickupSet, though I did notice that it was setting the objects dirty too often for prefabs. I'll take a look at fixing that for the next version.
 

nathanj

Member
Hey Justin,

The Runtime Pickups in the PunGame component:

RP.PNG

Sorry for the large image.

I can not add items to this in my scene or the demo and i confirmed with another user that they are having the same experience.

Thanks again,
Nathan
 

nathanj

Member
Also, just changed my Update Location from Update to Fixed Update (as suggested in the post you linked above) and it resolved the jumping and camera issues on master build!
 

Justin

Administrator
Staff member
I just tried to reproduce the runtime array issue but wasn't able to:

runtime.gif

I'll try it on Unity 2019.3 as well before we ship the next version.

Also, just changed my Update Location from Update to Fixed Update (as suggested in the post you linked above) and it resolved the jumping and camera issues on master build!
Awesome!
 
Top