How do you do ANYTHING with this?


New member
I'm on my 9th install of UCC and UIS. I have followed the integration and setup tutorials SO MANY times. It ALWYAYS ends badly with weird errors that don't makes sense. I get crashes involving the integration manager a lot. (I also get plenty of crashes if I use behavior designer). I can recite the tutorial videos word for word as you guys bumble around and try to set things up and act surprised when they do or don't work. Things will work fine and then I can come back to start working again and they don't. If I make changes, sometimes I have to remove everything from my loadout and re-add them to get rid of errors, even though I didn't do anything that dealt with anything involving items. I made changes to the equipment panel in UIS and suddenly I get errors relating to my character not having a look view or whatever, like a poorly setup AI. It just doesn't end. There are endless errors and errors and crashes that lead to more errors. I've used two different computers and now NINE INSTALLS of unity and this bloatware. It is bugged. There are so many bugs. As soon as I start trying to move beyond things covered in the tutorials, the entire setup collapses in to errors and crashes and compete trash.

I want it to work. It'd be super great if it worked even close to as advertised.

Here is my question: who is actually using UCC and UIS and getting great results that saved you time? I've wasted over two weeks trying to get anywhere and it is just frustrating because there are always more errors that popup. I don't even have to change anything to get new errors. It just breaks. The UCC and IUS integration seems really bad to me. I have a whole folder of crash files involving it. I also get crashes relating to the behavior designer integration, but most of my installs never make it that far before I just start over.unity_crash_logs1.jpg
That is an unusual amount of crashes. What is the stack trace of the crashes that are occurring? The character controller and inventory are pure C# so they are run within a managed environment. If Unity completely crashes it's generally a deeper problem on the Unity side of things since no matter what you do C# should never be able to crash the application. It may just be a buggy Unity version that you are using - are you using an LTS? In any case having the stack trace will help identify the issue.
I'm using 2021.3.19f1

It doesn't usually crash when playing. It crashes when compiling the scripts before it plays. Or sometimes I just make a change and it starts recompiling and crashes. Never had any problem like this before I installed Opsive stuff. Had been using this Unity setup for almost a year before that.

I was able to equip body, sword, shield, and an item I made that used slot 2. Everything worked. Then after I messed with the equipment panel using the UI Designer for the inventory for UIS, and don't think I even changed anything, and everything went sideways. It just keeps happening and happening, though. The first two errors beflow I don't know where they came from. But the rest are what I get when I put Body in my loadout to be equipped with default settings.

But if I start over again with a fresh database and install, I'll just get more errors. It has happened a lot. And doesn't seem like errors like "Hey, your loadout is directed to the wrong place." Overall, even with the tutorials and demos, the majority of the scripts are heavily convoluted and confusing. Like making a magic "item" or magic effect or spell or whatever. There are so many modules and it isn't clear when or why to use them. Like the six different places you can apply damage that doesn't show up anyway. It is all very frustrating even when it works. opsiveisatimesink.jpg
Can you try updating to the latest version of 2021.3 to see if that fixes it? THe current version is 2021.3.25.

With that said, the very first error relates to these posts:

If you are getting an error it's best the fix the first error because the others may be causing the rest.

Did you import all of the files when importing the asset? Based off of that error it almost looks like some of the demo assets are not included and that is causing problems. If you did import all of the assets and are still getting the error if you can send your project to we can take a closer look and see why you are running into that error.
I'm super frustrated but I appreciate you taking the time to respond. I'm sure you have a lot on your plate. I will try the newer version of Unity and see what happens. I've had a lot of issues where things seem inconsistent, though. Something will work and then just not. But I can actually do all of the tutorial setups from memory now so it shouldn't take long to see if this makes a difference.