Getting error with UCC integration on 1.7.1 and Third Person Controller 2.3.5

dasjlm

Member
Errors like following:

Assets\Behavior Designer\Integrations\UltimateCharacterController\Scripts\Tasks\StartStopInteract.cs(24,28): error CS0039: Cannot convert type 'Ability' to 'Opsive.UltimateCharacterController.Character.Abilities.Interact' via a reference conversion, boxing conversion, unboxing conversion, wrapping conversion, or null type conversion


Assets\Behavior Designer\Integrations\UltimateCharacterController\Scripts\Tasks\IsAbilityActive.cs(43,45): error CS0029: Cannot implicitly convert type 'Opsive.UltimateCharacterController.Character.Abilities.Ability' to 'Ability'


Not sure what is going on so I deleted the Opsive and Behaviour Designer folders and did fresh install but still getting errors as soon as I install the integration.



Any ideas?

Thanks in advance.
John
 

DavidC

Active member
Did you delete the integration from UCC folders, redownload, and reinstall it? Looks like it's in there.
 

dasjlm

Member
I was able to get it to work on new project with no issues, but deleting UCC and BD folders and reinstall on existing project did not work. Might be conflict with another product? Think I install products on new project to see what happens. Anyone I can proceed that was as fairly new project.
 

Justin

Administrator
Staff member
Have you tried a fresh project? My bet is that it relates to the namespace issue described under import errors:

 
Top