Bad picture (not smooth) with XR Plug-in Management

MikeSimpson

New member
When I use the XR Plug-in Management in Unity 2019.3 / 2019.4 with the VR demo scene, the picture is kind of lacking or like a double picture when I move my head, not smooth. When using the old "Virtual Reality Supported" option in the Player settings, the picture is smooth.
Do you have any idea how to fix that or what settings might be wrong?
 

Justin

Administrator
Staff member
It sounds like something is causing a slowdown. If you profile your game can you tell what is the bottleneck?
 

MikeSimpson

New member
That is the case with a clean install of UFPS & VR Add on and if I start the VR Demo scene. If I setup the XR Plug-in Management this happened, if I switch to "Virtual Reality Supported", then it is OK.
I have no idea how to read the profile settings, but for me they looked ok.
If you want to have a look, you can download the data files here: Files
One is the result with XR Plug in and one without.
Again, that was the plane Demo from the VR Plug in.
I am using Oculus Rift, Intel i7 6700k CPU and Nvidia GTX 1060 6GB
 

Justin

Administrator
Staff member
I just tested the VR add-on with 2019.3 and didn't have any framerate issues. From the VR add-on perspective it shouldn't matter which method you use as the add-on doesn't do any rendering. This sounds like it could be a bug on the Unity side. I would report it to them and see what they say.
 

MikeSimpson

New member
Thank you for trying. It is now working again. I think it was a problem with the "Tracked Pose Driver". I may have attached it to the wrong camera.
With the "Tracked Pose Driver" attached to the VR Camera and with the default settings it works now. Screenshot.JPGTo get the right position, I had to set the "Anchor Offset" in the Camera (not the VR Camera) from 1.8 to 0. (In case someone is looking how to set it up)
 
Top