ANIMATION PROBLEM: IT DOES NOT AIM

Ramarolo

New member
Hi all,

I am a user of the old UFPS, and now I am a user of Ultimate Character Controller. I am having an issue do not let work with this asset. After setting the Setup, Character, Item Types and Item, when I press play, every animation is fine (walk, jump, iddle) excepting AIM with weapon. When I press right mouse button, the Character Nolan only makes the camera get closer, like zooming, but he does not move anything in his body (he does not raise his arms to aim), so I can not aim, I can not shoot....I tried in both perspectives: first and third, but it is the same result.

I follow all video tutorials, and I tried in different Unity projects, but no way of AIM.

Why the character does not aim?

I await a response.

Thanks,

Rafael
 

Justin

Administrator
Staff member
To get started, does the demo scene work correctly?

Within your own scene do you have the Aim ability on the Ultimate Character Locomotion component?
 

Ramarolo

New member
To get started, does the demo scene work correctly?

Within your own scene do you have the Aim ability on the Ultimate Character Locomotion component?
Hi Justin,

I saw your Asset Store review, and of course I will change it if we manage the asset to work.

By "Aim ability on the Ultimate Character Locomotion component" do you mean Aim, into the Item Abilities, into the Ultimate Character Locomotion script of the prefab Nolan, that is the character in the scene?

I attach photo:

1578687053689.png

I did not know the existence of the demo scene despite "the demo" is mentioned a lot of times in the videos, maybe you could make a folder _Scenes, but anyway, I tried the Demo scene and everything works fine. In other scenes or projects, I experience the commented issue.
 

Justin

Administrator
Staff member
I saw your Asset Store review, and of course I will change it if we manage the asset to work.
Appreciate it - we will definitely be able to get it working :) If you don't mind removing it while we work to get it working I'd appreciate it!

By "Aim ability on the Ultimate Character Locomotion component" do you mean Aim, into the Item Abilities, into the Ultimate Character Locomotion script of the prefab Nolan, that is the character in the scene?
Yes, that's correct. Things look like they are setup correctly on your character. When you open the animator controller does the Slot0ItemStateIndex have a value of 1? This value corresponds to the Item State Index value specified within the Aim ability:

1578687691306.png

One other thing that I thought of, do you have any items equipped? If you don't have any items equipped then the aim ability could be triggering but the default animator doesn't go anywhere.

I did not know the existence of the demo scene despite "the demo" is mentioned a lot of times in the videos, maybe you could make a folder _Scenes, but anyway, I tried the Demo scene and everything works fine.
Good to hear. Yes, the demo scene is within the Opsive/UltimateCharacterController/Demo folder and not directly within the root Scenes folder.

If you want to send me the scene that you are working with I can take a quick look. Since you are using the demo assets you should only need to send me the scene as I have all of the other assets.
 

Ramarolo

New member
Ok I already removed my review.

You are right, as I am using your same elements, the best is to send you the Scene to check. I attach it. Tell me what is wrong because I guess I followed all the youtube video steps.
 

Attachments

Justin

Administrator
Staff member
Thanks! It looks like your shotgun has an Animator Item ID of zero so the animator doesn't know which weapon to aim with. You can change this within Nolan -> Items -> MyShotgun -> Animator Item ID. The shotgun has a default id of 3:


This will then allow your character to aim. There are positioning issues which you can fix by watching the first part of this video:

 

Ramarolo

New member
Thanks! It looks like your shotgun has an Animator Item ID of zero so the animator doesn't know which weapon to aim with. You can change this within Nolan -> Items -> MyShotgun -> Animator Item ID. The shotgun has a default id of 3:


This will then allow your character to aim. There are positioning issues which you can fix by watching the first part of this video:

Thanks! It was an ID problem and now the Shotgun aim and shoot.

I have an issue from the very beginning and I think is the time to ask. Always when I hit Play, the First Person Camera changes on its own Renders to Solid Color, and Culling Mask to Debris, despite being previously set up in any other way, so when I hit play I only see NolanFirstPersonArms and a blue Background. How can I change it to be the same as Edit Mode? I understand it can be set up to hide ThirdPersonObjects, but it is hiding also the floor.

And the new one after properly setting the Fire point, Muzzle Flas and Eject Point, according to the video, when I shoot the Muzzle Flash prefab appears and stays back the armor (I positioned it in the logical exit of the armor) without disappearing. and accumulating one more muzzle flash per shoot. Why it is happening?
1579044841516.png

I attach scene
 

Attachments

Justin

Administrator
Staff member
Always when I hit Play, the First Person Camera changes on its own Renders to Solid Color, and Culling Mask to Debris, despite being previously set up in any other way, so when I hit play I only see NolanFirstPersonArms and a blue Background. How can I change it to be the same as Edit Mode? I understand it can be set up to hide ThirdPersonObjects, but it is hiding also the floor.
When the game starts the First Person View Type will set the first person camera's field of view, clear flags, culling mas, depth, and rect. The culling mask is set to the value indicated by the First Person Culling Mask property. I'm not sure what is changing the renders as the controller doesn't change that. The controller doesn't use a Debris layer so this is likely something is setup in your own project.

And the new one after properly setting the Fire point, Muzzle Flas and Eject Point, according to the video, when I shoot the Muzzle Flash prefab appears and stays back the armor (I positioned it in the logical exit of the armor) without disappearing. and accumulating one more muzzle flash per shoot. Why it is happening?
What does your muzzle flash prefab look like? Does it have the Muzzle Flash component on it?
 

Ramarolo

New member
When the game starts the First Person View Type will set the first person camera's field of view, clear flags, culling mas, depth, and rect. The culling mask is set to the value indicated by the First Person Culling Mask property. I'm not sure what is changing the renders as the controller doesn't change that. The controller doesn't use a Debris layer so this is likely something is setup in your own project.


What does your muzzle flash prefab look like? Does it have the Muzzle Flash component on it?
After some days almost fully working in fixing the render issue of the asset, I realized searching in your documentation that this happened in all my projects because they are LWRP or HDRP, because I tried the project in a normal 3D rendering pipeline project and the problem dissapear. Next photo shows how it is seen the First Person Camera in LWRP and HDRP.
1579219408369.png
In this link of your documentation says https://opsive.com/support/documentation/ultimate-character-controller/camera/lightweight-render-pipeline/ that there is a method to avoid this blue screen and be able to work normally in LWRP following the process fo this video from Unity:
but the video is a different case, it is only first person, is not both person perspective like we work and I need in UCC. Anyway, I tried the Unity youtube process and I followed your steps of the mentioned link until the step 4, because in my Camera Controller there is no Overlay Render Type section, so I can not fix the issue.1579219885723.png
The Main Camera works good, but the First Person Camera does not allow to set up Background to Skybox, do not conserve the Culling Mask Configuration, etc...because when you hit play all settings came back to default state, and I guess it is because what you say in the doc "This works well for the standard pipeline, but the lightweight render pipeline does not support camera stacking so another solution needs to be used. "

I attach the scene of the project to let you check it in a LWRP project, and if needed I gladly send you the full project to definitely solve this at once.

Thanks.
 

Attachments

Justin

Administrator
Staff member
I followed your steps of the mentioned link until the step 4, because in my Camera Controller there is no Overlay Render Type section, so I can not fix the issue
What version of Unity are you using? Did you download the LWRP integration from the integrations page? The render type will change if you have this integration downloaded. Right now only LWRP on Unity 2019.2 is supported with that integration.

HDRP currently is not supported - it will be supported after it is out of preview and supports modifying the stencil buffer.
 

Ramarolo

New member
I am gonna send you screenshots of the project:
1579262347436.png
Unity 2019.2.0f1
1579262484807.png
Also the recommended version in Asset Store of UCC for LWRP.
ScreetShot of the camera created by the Main Manager of the asset:

1579262693013.png
As you can see, it has no Overlay Render Type Unity option, only Render Type where I test the Use Pipeline default option, and the ForwardRenderer created according to the Unity video that you suggest.
Also, I thought that you wanted to mean the script Camera Controller that is created in the camera when you hit Set Up camera in the asset (I still have no clear) but there is no overlay in the script.
If you do not know the fix, try to download my Unity version to know if it is possible to render properly the asset in it. If not, I will send you my full project.
 

Justin

Administrator
Staff member
Did you download the LWRP integration?


Also, I thought that you wanted to mean the script Camera Controller that is created in the camera when you hit Set Up camera in the asset (I still have no clear) but there is no overlay in the script.
That is correct. The render type is specified on the Camera Controller component, not the Camera component. You can manually enable this by adding ULTIMATE_CHARACTER_CONTROLLER_LWRP to the player settings. This option can be added to the Scripting Defined Symbols of the Configuration section.
 

Ramarolo

New member
Did you download the LWRP integration?


I did not know about its existence, but I already downloaded and Imported it to the project. Ater doing so, I received these warning messages related to the OverlayLWRP
1579283343440.png



That is correct. The render type is specified on the Camera Controller component, not the Camera component. You can manually enable this by adding ULTIMATE_CHARACTER_CONTROLLER_LWRP to the player settings. This option can be added to the Scripting Defined Symbols of the Configuration section.
Not sure what it is for, but yes, it was written already, but still no Overly Render Type on the Camera Controller:
1579283650113.png
 

Justin

Administrator
Staff member
That looks correct. On the Camera Controller you'll need to make sure you expand the View Types foldout and select the First Person Combat View Type. This will have the overlay property - it's not directly on the Camera Controller.

1579284571035.png
 

Ramarolo

New member
I selected First Person Combat, but I have no this Overlay Render Type option. Photo:
1579289232533.png
Here you have a link to my project allocated in google drive, please download and check to make it work:
 
Last edited by a moderator:

Justin

Administrator
Staff member
Please do not attach the project directly - this is a public forum and not everybody has a license to UCC. I'll let you know after I have a chance to look at it.
 

Justin

Administrator
Staff member
No worries. The posts are viewable by anyone, and anybody with an invoice can register versus having it specific to UCC.

I took a quick look at your project and you are running version 2.1.7. If you update to the latest version that option will be available. You'll also need to download the LWRP integration:

 
Top