AI Use rate too slow?

Vlaxep

Member
Hi,

I've got a basic enemy using the 'Solo' behaviour (using BD and DeathmatchKit).

The AI Enemy has a shootable weapon using Assault rifle type setup, for an SMG-like weapon.

I want to have a high fire-rate like an Uzi for example, but changing the 'UseRate' in shootableWeapon doesn't speed it up.

At 0.1 my PlayerCharacter's Assault rifle weapon repeats very fast, but on the same setting the AI firesabout 1/2 to 1 time slower again. Not sure if it's animation related or behaviour or something else?

The AI's weapon is set to 'FullAuto' and 'Instant'

Also in the ThirdPersonShootableWeaonProperties, i set the 'LookSensitivity' to -1 in case the recoil was stopping it from firing until aimed more directly, but no change.

ShootableWeapon settings below....
1641814017943.png
 

Justin

Administrator
Staff member
This is likely related to your behavior tree. You'll want to make sure the use ability keeps repeating so the weapon knows to fire.
 

Vlaxep

Member
This is likely related to your behavior tree. You'll want to make sure the use ability keeps repeating so the weapon knows to fire.
Thanks. I haven't altered the Behaviour tree, so what is causing the 'use' to be intermittent/interrupted?

It appears to be continuous when viewing the behavior designer window?! The green nodes below are continous throughout the time that the AI is firing at the player, there is no break, all stays green.

1641900427511.png
 

Justin

Administrator
Staff member
Can you insert a breakpoint within the Use ability to see if it continuously gets called? There is a lot that can prevent the item from being used so it's hard to say exactly what is delaying it.
 
Top